為什麼需要sass

在撰寫CSS的時候,相信你一定會遇到一些累贅的狀況。
明明是重複的地方,為什麼想要一個一個修改?

安裝方式

1
gem install sass

如果顯示permission denied無法安裝,表示權限不足,需要加上sudo

1
sudo gem install sass

但是在mac上可能會出現build failed
你需要安裝developer tool才可以執行

1
xcode-select --install

巢狀選擇器 - Nesting selectors